Erro no backup da base de dados

Desvendando o erro “Are you sure you want to do this?” no WordPress ao realizar backup dos dados utilizando o plugin wp-db-backup

Estou utilizando o conhecido plugin wp-db-backup, o qual é excelente para executar e agendar backups dos dados do blog wordpress. Mas estou esbarrando em limitações do meu plano de hospedagem…

Sempre antes de atualizamos o blog para uma nova versão do WordPress, somos avisados que é seguro antes fazermos um backup do banco de dados. Pois bem, fui até a configuração do wp-db-backup para realizar um backup de segurança, apesar de ter agendado um backup semanal, a ser enviado por e-mail. Foi aí que me dei conta que já não tenho recebido há um bom tempo tais e-mails com backups.

Assim, ao executar manualmente um backup aparece uma tela com a seguinte mensagem:

Are you sure you want to do this?

Algum problema ocorreu e a mensagem não é nada intuitiva. Procurei no Google e neste link alguns usuários também reportaram o mesmo problema, mas sem solução. Foi aí que começei a procurar saber se o WordPress contém arquivos de LOG ou se eu deveria procurar no próprio servidor onde o mesmo está hospedado.

Encontrei o seguinte link e, por coincidência, o autor do texto tratava de um servidor onde continha o gerenciador Plesk, o mesmo utilizado pelo www.integrator.com.br, onde meu blog está hospedado. Fui em Log Manager do Plesk e abri o arquivo error_log. Finalmente encontrei o erro:

PHP Fatal error: Allowed memory size of 78643200 bytes exhausted (tried to allocate 23322392 bytes) in /var/www/vhosts/<meu_blog>/httpdocs/wp-content/plugins/wp-db-backup/wp-db-backup.php on line 1025

Provavelmente há muito tempo não são feitos backups do banco de dados do meu blog, por causa deste erro. A solução seria aumentar o limite de memória utilizada pelo PHP, alterando o arquivo wp-config.php. Todavia, o suporte da Integrator me informou que meu plano de hospedagem permite até 75Mb. Só preciso saber agora se terei que parar de usar o plugin wp-db-backup, passando a realizar backups manualmente, através do MySqlPhpAdmin, ou se valerá a pena fazer um upgrade de memória no Integrator (pouco provável).

WordPress 3.0 Upgrade

WordPress 3.0 Upgrade – “Sem permissões suficientes para acessar esta página”

Se você fez o upgrade do WordPress para a versão 3.0 e tomou o seguinte erro “Sem permissões suficientes para acessar esta página” ao tentar entrar na console de administração, basta remover os seguintes arquivos do diretório /wp-content/languages:

pt_BR.php

pt_BR.po

Fontes: Link 1, Link 2

Abraços.

“Sem permissões suficientes para acessar esta página”

Galeria de fotos

Uma pequena demonstração da minha futura página de álbuns, usando o plugin FLAGallery.

Abaixo uma demonstração da minha página de álbuns, que pretendo criar. Só gostaria de saber como criar permissão de visualização para esta página. Alguém sabe?

[flagallery gid=1 name=”Gallery” stylishgrey]

Gostou deste slideshow? Trata-se de um plugin do WordPress chamado FLAGallery (Flash Album Gallery). Existem ainda skinks gratuitos disponíveis, os quais podem ser encontrados em http://photogallerycreator.com